Unable to update HomeBase 2 Firmware

I’m attempting to update the firmware on my Homebase2, from it’s current v2.1.0.9h.

I’ve tried About Device > check for Firmware update > Latest firmware is available > Update. This proceeds to tell me ‘All of uyour devices are updating…this will take a few minutes’ Nothing happen, no update.

I’ve also tried a full reset (Pin in the back, wait for the voice saying HomeBase is reseting), then add homeBase back in, and get a different prompt to update. This appears to download, but fails after about 5 mins, repeating also fails. - See screenshot.

Any other way to update the firmware, or is this Homebase now faulty?


I wouldn’t worry about it. Eufy puts firmware out on a rolling update schedule, which means not all users get the latest version at the same time. It may also be that the latest version has been found to have bugs that need fixing and they decided to postpone the update. Unless you know you need something in the current update, I’d just wait until it comes automatically. If that won’t work for you, contact support and they can push it to you device if needed.