Unable to play live video problem outside home network


I have 3pcs Eufycam 2 pro cameras , 2k doorbell camera connected to homebase2.
2pcs indoor camera witch are connected straight to wifi.
All works great when I’m home wifi. But outside the home network is painful to get connect to any off those cameras. I have great 4G connection at my iPhone 12 Pro max but when try to open camera I see first “establishing secure video channel and after that, unable to play live video.” I need to reconnect at least 5-10 times to get successful connection. Many times takes 20 reconnection to get live stream open.
Connection between camera and home base are great. Wifi connection to indoor camera are great. At wifi connection works always and fast but no outside home network. When using guest wifi outside home connection is better than using 4G, but not work always.

I have set every camera video stream quality to auto/poor but that’s not help.
Notification at doorbell camera works great, but when it takes 5-15min to get live stream or see record what is the point whole notification and products ?

Same problem are when try to view recording at 4G but that works little bit often than live stream

Before these cameras I have Logi circle cameras and those works great and I get instant live view no matter if I was home or outside networks. So I thing that problem is your cloud service or whatever connection that app use.

Other problem is geofencing, That not works at all. Sometimes mode changes instantly when come or leave area, sometimes takes 30min, sometimes have to change mode manually.


I have the same problem with my doorbell through WiFi there’s no problem but on 4G with different iPhone there isn’t any contact.

This is in my eyes since the last update there is a problem that is blocking outside communication.

1 Like

Other people here and on Reddit have had similar problems, but its not a firmware issue or everyone would be having trouble. It could be your ISP or firewall blocking either the video stream or the metadata that get sent to AWS to tell your phone where to get the stream. Does the Eufy Web Portal work for your system?

If you need to link to the web portal, the link below doesn’t seen to work from this site, but if you copy and paste it into a browser will take you directly to the web portal.



I have the exact same problem with the Eufy 2K camera (I see first “establishing secure video channel" and after that, unable to play live video.”). With the Wi-Fi connection without problems but with the 4G connection it does not reproduce, very rarely I get it. In the web portal it always reproduces correctly.
IPhone X IOS 15 (Beta RC)
Eufy IndoorCam P24 2K (firm

@DarkEvilRivas Sounds like the issue has to do with your Iphone since the web portal works. That means the stream address metadata and connection from your router are working. There have been several posts about the same issue and most seem to happen with IOS. If you are on a Beta release of IOS, I don’t know what to tell you. It seems to me that someone fixed this problem by editing their APN so it used IPv4 instead of IPv6. You might try searching here and on Reddit for posts about this problem.

If you don’t have any luck, try to contact Eufy support by email. The phone and chat people seem to be just script readers and usually are no help. Sending an email ensures a ticket is created and might get you a solution.

Same here, I have the problem, too! I have the Eufy 2K in another apartment. Internetconnection is normaly fine and I hadnt issues until today. My iPhone X is connected to another WiFi in another town, but Im not able to connect anymore. Until today, it worked perfect. I tried normal LTE with my phone, too, but no response. And i tried it on the Computer. …“The camera is offline”. :frowning: I´m not able to drive multiple hours to the eufy-cam to reset it… I hope thats a server-issue and I hope it will be fixed in the next hours without requiring me to drive there and reset it…

This is a chaos. You can see more cases in the forum:

I have the same problem as the initial post states. It just started happening about 2-3 weeks ago. Nothing changed on my side of things. Same phone, same equipment, same everything. I thought it might be a firmware upgrade or something but from what I’m reading that does not appear to be the case.

Homebase 2 + eufycam 2 pro

I am having issues connecting to the homebase via ios app. I get the error unable to connect to homebase (-2) . Cameras are at my home in another country, fully updated , full battery and also connected to eufy solar panels. I am receiving notifications that someone has been spotted but when i open the eufy ios app to see recordings or to live view i get the error mentioned above. I had tried to restart the homebase several times, uninstall and install the ios app but the same problem.

Sometimes it works to connect via mobile data but not on my wifi.

I had also tried to disable the firewall both at the home network were homebase is connected via ethernet cable, and also disabled the firewall on the network i am now and wish to connect.

When i use eufy website to see the cameras over there it works, but not on the mobile phone. I had also tried on diffeRent phones, still not working.

Please help !!!

After 4 months with no problem at all with Homebase 2 pro , i have the same problem but I’m on Android… i get a “can’t play live video” end if i hit “retry” i get the message "unable to connect to Homebase (-3).
that’s only if I’m on a 4G or using not my home’s wifi… i don’t get also notifications…i get 2 or 3 for all day but not from the correct time and not all of them…
So i though something was happening to my home but when i get there today it connected to the system and start giving me all the notifications and i could start or change the properties of the cams as before.
Went out and still the problem exists again… 2 cam2 pro 1 indoor cam pan& tilt and 1 entry sensor… what could be the answer to this?.. the system was working with no problem 4 to almost 5 months… all this started at 18/9/21 in the morning… the Homebase is connected with the wire to the modem.

I tested now when the home as 2 is connected to wifi and it works more reliable now. Very strange that connected the home base with enternet give the most problems.

I have an iPhone 11 Pro Max which has an EE e-sim and Vodafone physical sim. I can connect to my eufy system via the app when on any wifi network but I can’t connect to the cameras when not on wifi (e.g. 3G/4G). I have some eufycam 2 pro’s on my system and up until recently I didn’t have this issue and it worked completely normally.

I have worked out that if I go to settings - mobile data -
select the Vodafone data plan (the one on the physical sim) and select the “turn on this line” to off. I can then access my cameras on the eufy app when not on wifi so it all works.

This must be related to a software issue with the eufy app/system as it all worked before.

I was using it for at least 4 months with the enternet with no problem… must be from eufy program an update maybe made that problem…

Just wrote email to support address. Nice to see what they answer, I think they just ask to check my internet connection or something else useless generally advice. hopefully they will take this problem seriously.

Couple days ago postman was behind the door and notification works perfect, but surprise video connection not work and I cannot say that you can leave the package on the door. After 5 minutes when live stream finally opened it was already late.

I have a similar situation on my iPhone. As soon as I switch from wifi to 4G I cannot connect to my Eufy indoor camera. Somehow when I turn the regular line off and just keep the e-sim line working (KPN in my case), it starts working again.

Webportal,4G, iPhone and Android al the same. But still have the homebase 2 through wifi and now it’s still stable enough.

That sounds like something is blocking outgoing data at your router. Eufy needs some metadata that points to your homebase so you can retrieve live views and events. The Web Portal needs the same kind of data. If they all act the same, its probably either router or carrier blocking some ports. You could try to run your Homebase off of a Wifi hotspot on your phone and see if that gets through. Other than that, you are probably stuck with contacting support.

Same here for me, I have solarcam so no homebase, I have to disable my esim to play live by my physical sim.

Something strange too, if i use my esim on « default data » it works, i can keep both sim and live on my cam.

Not my best solution because my physical sim has more data available.

Any solution to this yet? I’ve been having the same issue since purchase and I’m thinking about going a different route.

I posted in another thread, and wanted to put this in here. I had to disable my firewall in my cable router to get the 4g LTE access to work. Now i have full access. Just wanted to share my fix just in case it might help others.