Unable to get Homebase 2 or cams working, no WiFi issues on anything else

Don’t know if Eufy servers are down but I haven’t been able to connect Homebase 2 or cams today, and I was trying to mount cams outside. Thought I’d check they were working first, neither camera would connect, then Homebase wouldn’t connect. Removed all in the app, started again to try and add but can’t. There are no issues with my wifi, I also tried connecting homebase to router with Ethernet cable again to make sure but the app still couldn’t get it to connect. When I first set everything up two weeks back to check it was OK after delivery, everything worked fine. Any advice appreciated. Thanks

Which cameras do you have and did you try restarting them as well as the Homebase 2?

Eufy cam 2 and yes. When none of it worked, I removed all cameras and the homebase 2 but when trying to add them all back in, I keep getting “can’t connect” error messages. Was thinking of trying a hard reset on the homebase but not sure. My Mobile is fine, my WiFi is also OK, so it’s the Eufy equipment that’s not working

Did you try restarting the modem, then router, make sure you’re in 2.4GHz in your phone?
Check the Homebase 2 and cameras to see if they need a firmware update.
The Homebase 2 might need to be reset but I’ve read were after waiting some time the system will work again.
The cameras should have plenty of battery but maybe charge them up. Are they close to the Homebase 2 when connecting?
Try repairing the internal storage on the Homebase 2.
Try using another WiFi

I’ve been adding things to my system all day and moving devices around. Haven’t seen any hiccups with Eufy servers. They use Amazon’s AWS infrastructure, so it’s pretty reliable.

1 Like

Thanks all, I restarted the router and Homebase and it all worked OK this time, so added cams, mounted them outside, and testing tonight. Must say there’s quite a lag between motion and detection, and when playing live it’s a bit jumpy. Also seems to be reducing the streaming quality of programs I’m watching on my Roku, and I have 70 meg broadband download and 22 meg upload so would have thought it would be sufficient for both? Anyone else had this problem?