Unable to connect to homebase (-12) pls help

My Eufy camera system and home base 2 worked great for about 6 months. Now I am no longer able to use my cell phone to look on my cameras at home or see who’s at my front door without getting the above listed error message. Nothing has changed with my Wi-Fi my phone or any of the settings. The weird part is that 1 of the persons in my home can still log in no problem and see the camera feeds but I cannot.
I’m trying to log in in places where I have full signal strength of 5G connection as well.

(-12) code = unstable network.
Since the other person in your home is able to access the camera I don’t believe it to be a home base problem.
Try restarting your phone if you haven’t done so yet to see if that solves the problem.
If not connect your phone to your home’s Wi-Fi to see if you can access the camera then.

Restarted phone. Same issue.
When on wifi, my phone connects to Homebase fine.
I have good signal: 5G. I can easily stream video from Youtube and others when away from home so bandwidth is not issue…
I noticed the problem started when you click on camera event and the loading icon was a eufy “shield”. When loading icon for events was previously a circle it was fine, i could see camera events.
I even uninstalled then reinstalled eufy app…same result. Unable to load live camera feed or view events when im on cellular.

Could be a cellular communication problem? Did your phone always have 5G? And is the other phone using 5G also?

Can you switch your phone to not use 5G and tell it to use 4G instead, just to test it out?

Both phones on same network. Identical model Samsung s21.

Tried 4g…same result. I’ve always had 5g…so not sure what’s going on.

Both of us have same admin privileges if that matters.

I’m a computer tech, but nothing makes sense why it all of a sudden stopped working…

Feeling like I invested $1500 on garbage.

One more thought came up… Is the other person’s phone running the same App version?
After that I can’t think of anything else that may help.
Last resort restart the home base?

Copy. Gonna try that as soon as I get home. Appreciate your help.

Sounds like your connection timed out. Switch to cellular and try it. If it works without the Wi-Fi then the connection timed out. This happened on my Arlo app yesterday and switching worked. After a while, it worked again on Wi-Fi. Not sure why this happens.

So it just started working again. No changes made, I just basically left it for few days and it started working again.

Concerning it worked fine for a year, stopped working for weeks, then all of a sudden it worked again. The whole time, other users on same Homebase had no issues.