Unable to connect over mobile data

Hi. I’ve had the eufy 3 cam set up for about a week or so. Really struggling to work out why I can’t view the cameras while on mobile network (one of the main reasons I have them!). I’ve checked and double checked that I’ve allowed data roaming, along with all the permissions on the app, just won’t load up! It’s worked a handful of times, but for the most part, just says unable to load. I have strong 4g reception whenever I try. Any help greatly appreciated.


I’m having exactly the same issues so looking forward to the replies (sorry I can’t offer any advice)

I had the same problem in the past few weeks even though I reset all my devices.

Same problem. Wifi is ok. Dutch kpn not working. T-mobile is ok.

1 Like

Same here. But generally unable to connect when away. It worked a few months ago, but now? Nothing, neither WiFi nor mobile when I‘m not at home. Extremely annoying. Whole reason I got the cameras was to use them while away.

I have an iPhone 11 Pro Max which has an EE e-sim and Vodafone physical sim (I’m in the UK). I can connect to my eufy system via the app when on any wifi network but I can’t connect to the cameras when not on wifi (e.g. 3G/4G). I have some eufycam 2 pro’s on my system and up until recently I didn’t have this issue and it worked completely normally all the time.

I have worked out that if I go to settings - mobile data -
select the Vodafone data plan (the one on the physical sim) and select the “turn on this line” to off. I can then access my cameras on the eufy app when not on wifi so it all works.

This must be related to a software issue with the eufy app/system as it all worked before. Do you have a dual sim phone?

1 Like

Same problem. Homebase is connected with LAN cable and great reception on phone

I think I have the answer. A while back at the summer cabin the adsl was shut down and I bought a 4G router and sim. While being on wifi I could watch, while being on 4G I could not.

Turns out packets with ipv4 are cut off and ipv6 is needed for eufy. Isp made sure I had ipv6 and set that up in the router aswell but same issue.

Bought a more expensive 4G router and it worked out of the box.

I have email conversations mile long with eufy support regarding this. Why did my wyze, arlo, reolink and blink cameras work on that cheap router that cut of the packets between router and eufy homebase but not they eufy 2C. Guess their packets are longer? Its for sure a eufy feature.

Heard people needed to get their isp to make sure they get ipv6 home and activate that in their routers and some, like me that also needed a better router.

Heres more Unable to connect to Homebase (-3)

1 Like

Same issue here, samsung m31, but my wife movile (redmi note 9) works fine, but we have different ISP so I do not know if the problem is the ISP or that the app is wrong in some devices

Swap the sim and try them in each other’s phone, that will tell you if its the phone of the mobile provider (mostly as long as it’s not a setting as well).

Same issue. Except my doorbells work fine on cellular. My new pro floodlight however will not.

Exact same issue here with Eufy cameras as well as teh Doorbell… This is an issue with the app…

Had the same issue, but all is working now. But i figured it out. In the app, make sure to give Eufy access to mobile data on your phone.


Settings - App Permissions - Mobile Data.

This did the trick for me. Hope it will work for you as well.

Here are more threads and people reporting the same issue: https://www.reddit.com/r/eufy_security/comments/osm1ax/dual_sim_bug_eufy_security_ios_phone_not/

So it seems the issue stems from using either dual sim (e sim and normal sim) with the same carrier (Orange or Vodafone UK as others reported) or VoLTE (although this doesn’t work for newer devices such as iPhone 12 and beyon

Turn off ipv6 in your mobile settings. Leave only ipv4. Had the same issue, this worked.


How do you tuen off IP6, thanks

SOLUTION! Ok, so I thought no I have a possible workaround for this frustrating issue. I have downloaded Spedify which is a VPN app which allows you to use both WiFi and mobile data simultaneously, I’m not sure why this works, but I think it tricks the app into thinking that it’s using WiFi. I’ve tried running the app even without connecting to a WiFi networks and it finally works! Just to note, this is a work around and Eufy REALLY need to resolve this issue and hope this highlights and proves that their app developers need to sort this out! This issue mainly affect dual SIM devices, so let me know if this has worked for you guys.

Same problem here with Dual sim, 1virtual and 1 physical, if I turn off one of the sims from the phone settings it starts working ….
I’m using an iPhone.

1 Like

Thank you for the only usefull advice. The cameras worked some time fine via mobile connection, but suddenly stopped working. Only via WI-FI works. By removing one SIM card, they started working again. Thanks thanks!! Eufy should fix this problem so that cards can be used in iphone 2.