Unable to connect camera after 1 year usage - SOLUTION

After 1 year using couple weeks ago i was unable to get video feed from my both cameras.

Tried these things:

  • reset homestation
  • check wifi connection (ok)
  • remove and installed camera app to phone.

Model No. eufyCam
System versio 1.9.3
Subsystem versio

Does these cameras break just after warranty ends? Any one else had these problems?

Try connecting with the Eufy web portal? https://mysecurity.eufylife.com/#/login

Does your homebase show its online?

Have you or your ISP changed any software on your router?

Try to reboot router.

If none of these work, suggest you contact support@eufylife.com with information you posted.

I can get open_close door notifications from door sensors to phone (no wifi, over gsm network).

I can change security mode with phone, phone/app say unable to connect home base, but the mode still changes and i can see it from my eufy keybad (blue lights change to selected mode), in phone app mode doesnt update right.

I tested your web address and there i can see my camera feeds. So it looks like the phone app is some why stuck? Phone is galaxy note10+.

I have given all permissions and no battery save mode to eufy app in my phone.

Have you tried rebooting your phone? It sounds like something to do with the app and/or phone. If you can get notifications and see your cams on the web portal, that means the homebase is up and running and the cameras and sensors are working. Somehow, the app/phone isn’t connecting correctly.

Do you have the latest app version. Mine is 2.6.1_868US for android.

Hello i found solution.

-Restart homebase via phone app
-Phone was latest update
-App was reinstalled
-Phone was restarted
-App setting was checked on the phone permissions and battery save option.

These didnt work, but next thing looks lile helped:

First i tried to connect homebase straight to ethernet and it still didnt work but then i unplugged AC cable and made hard reset to base station (special button back off homebase), then it started workin.

I tought via phone app it would made hard reset right but some reason it didnt.

Hard reset behind homestation worked!