Solocam E40 won’t connect to wifi

I have 2 SoloCam E40s, and I can persuade neither of them to connect to my wifi. I have an Asus XT8 mesh wifi, with 2.4GHz on a separate SSID. I’m using the app on an iOS device. The XT8s are not on the latest firmware as that seemed to have some stability issues, but iOS and app are up to date. Setting up one of the cameras via the app, everything seems to go OK (set wifi network/password, read QR code), but then It sits at the ‘connecting to wifi’ stage, and eventually the camera voice will tell me it’s failed. After reading other comments in here, I’ve tried both turning off 2FA and setting up a phone hotspot. Neither made any difference. Now at a loss. Any suggestions?


Answering my own question.

I found a complaint on the forum about wifi password length only being supported up to 32 characters. My standard network password is longer. I setup a guest network with a password length <32, and low and behold it worked!

I’m not aware that 32 chars is a legitimate limit on wifi password length (happy to be corrected) so I have to conclude that this is a bug in the Asus implementation.

Hope this helps someone else!

WPA2 passwords can be up to 63 characters long .
So this is a weird limitation eufy put in place and makes no sense in my opinion.


Probably related to the field length and definition in their backend database. Have seen this in other products. There was an issue with certain special characters that weren’t supported at one time and that is usually related to database design as well.