Solocam E20 stuck on "is updating" and now unresponsive

I have a Solocam E20, woke up this morning to see it was showing “camera is updating” in the app.

It’s been a number of hours now and still nothing so I’ve taken it down and put it on charge.

Not really sure what to do now? Has my 2 day old camera bricked itself?

I have the. Same issue, mine has been showing as updating for the last 3 hours. Tried turning off/on, unpairing etc but it won’t let me do anything. Completely unresponsive

I’m having the same issue.not good for a week old camera doesn’t inspire confidence in this product.

Tried contacting Eufy, no one there, only available 8-11 am Mon to Friday. Brilliant!

Put on charge and isn’t even showing as charging??

Just had the same problem, contacted eufy, an engineer will email. 8sec reset doesnt work, no lights when charging. I think the firmware update has bricked it.

Same here… Going to leave it for a few hours whilst I wait for a reply from Eufy

Interesting. This morning the Eufy security app was showing. “update available, version”. The app is now saying that is the most recent one.

Tinfoil hat theory but maybe .9 was bricking devices and has been pulled…?

Another one here that is unresponsive!! Fancy paperweight now!!

I have the same problem

Anyone heard anything from eufy?

Just managed to get working again by doing a manual update.

Mine has just flashed red and blue firmware update and has started working again as I would expect, firmware is now updated to latest version. Battery though is down to 15% from full y charged yesterday. Looks like a server fix as mine has been accessing firmware update site fairly constantly over the last 12-24h. Suggest if you are having this problem leave charging and connected to wifi and it may fix itself as mine has.

Mine has just jumped to life

If you still can’t get your cam working, send an email to with the serial number of your device and the symptoms your are having. They should be able to push an update to your device. If the problem is big enough they probably have someone working in the back room who can do the fix over the weekend.

1 Like

I’ve contacted support who are now being very helpful :slightly_smiling_face:. Device is still totally unresponsive in my case.

My E20 woke up 24 hours later and I was able to reinstall it

How did you do a manual upgrade