Since update on my homebase 2 I get error unable to connect to homebase (-3)

My homebase 2 says it is on system version since 29-Oct-2020. Since then it has seemingly not captured or notified me of any movement on my video doorbell or either eufycam2’s (there should be 20+ per day). I can play old captured clips on the phone app, but if I try to change any setting I get error: unable to connect to homebase (-3). I have tried restarting, power off/on, restarting cams etc no luck. Is this a bad firmware update? Any workaround anyone can suggest?

1 Like

The firmware should be good. One last resort which might help is resetting the homebase. I did that once by holding the sync button for a while, instead of the tiny reset button.

John0, thanks for the response. I’ve now tried holding down the sync button, nothing happens at all. I’ve also tried to resync doorbell with homebase, as far as I can tell that doesn’t work either. Either the firmware or the firmware update process are clearly not good, as at least one other user is having same issue.


I’m sorry to hear you’re having this issue after your latest update which has happened to me twice after receiving updates on my Homebase 2’s.
My original Homebase 2 had numerous updates with no issues with my Linksys Velop Mesh System since May 2020 when I bought the 2 2C camera kit. Everything was humming along until I received a update at the end of September when I had your exact situation except I had a update loop that never actually finished updating to the new version. I tried several of the Eufy support basic suggestions which didn’t work and then after sending them my Eufy app logs, they determined that I needed a new Homebase 2 which they sent. I successfully updated the second Homebase 2 to the latest firmware version and everything worked fine until they sent another update which but my Homebase 2 into another update loop and they’re trying to figure out what to do next. I read online that someone used an old router to update the Homebase 2 which worked for me, but when I switched back to the Velop mesh system all I get is the live camera feeds. I still get the unable to connect to the Homebase error message just like you.
Have you tried just turning off then on the cameras? I’ve read that this helps sometimes.


Thank you for the reply. Yes I tried turning off/on the cameras by pressing the sync button 5 times, sae with doorbell, but it didn’t seem to help. I do notice that I now get a different error when I try to change anything, it now says unable to connect to homesbase (-1). Maybe that means I’m making progress and should try a few more things…

I’ve read posts that the notifications and events have come back for some so keep trying. Have you checked to make sure they’re selected in your settings such as Tank has mentioned before?

What’s your network setup? Do you have a modem/router combo or a separate modem and router? Are you using a mesh system?


Notifications are back! I restarted everything again, router, homebase, doorbell, cams, mobile app… and now I see notifications from the weekend. So the homebase was clearly receiving them from the doorbell and cams, just not pushing them out. Also weird that when you select notifications for a device it showed it was clearly filtering

Good news that its back. Although the behaviour is very strange. I was led to believe by reviews that Eufy products were much move ‘local’ than other products, but this behaviour leads me to believe that the Homebase phones home everytime before it even notifies you of an event. Do you know is this the case?

1 Like

Excellent news! Did you reboot or reset the homebase?

I’m running into the exact same issue on my HomeBase 2 and 4 eufy 2 cameras.
I recently extended my network with an eero Pro 6 and everything went south at that point.
I can still live stream the cameras, but changing their settings or getting notifications is broken.
The indoor 2K eufyCam works just fine (but doesn’t connect/pair through HomeBase).

Waiting on eufy’s customer support feedback now.
I don’t really want to go resetting everything… if there’s another easier fix to try I’d like to hear it :slight_smile:

When it went south at the moment you switched network components, I don’t see how you point the finger at eufy.
Are you sure the settings of the eero 6 Pro are correctly configured?

Because I have over 50 wifi devices and the eufy is the only one that “broke”. Well, it’s not broken fully because I can still manually stream the cameras and I can connect to the HomeBase. Just no notifications anymore and can’t change the camera settings… So there is some weird network interdependency going on with the HomeBase setup that is not clear what.

@BandB, Before the Eero did you have a mesh network where you use a single SSID for both 2.4Ghz and 5Ghz as well as multiple “nodes”. Also is your homebase on WiFi or Ethernet?

I know a lot of IOT devices can have issues with mesh networks especially if you have the “nodes” too close and the power of each causes an overlap. I know with my 2.4 GHz smart plugs I needed to power down temporarily the 5Ghz network until setup was complete. I also periodically have an issue where my chromecast doesn’t see my phone because they are on different “nodes”

Maybe temporarily power down the eero “nodes” and see if that resolves your issue. If it does it might point to Eufy App having issues getting to the homebase when on a different “node/AP” from the homebase.

Thanks for the suggestion. This was just extending my eero mesh from 2x eero Pros to add a 3rd eero Pro 6 node.
I tried powering down all the other nodes except for the gateway eero, didn’t help unfortunately.

@gmogoody8, thank you for the lead. I think you were on the right track.
I was able to resolve my issue using the following steps:

  1. Change HomeBase back to Ethernet mode and reset the WiFi configuration (although my WiFi SSID never changed)
  2. Change HomeBase back to WiFi mode with a single node of my eero mesh network up (the gateway eero)
  3. Move my HomeBase 2 base to its original position in the house in WiFi repeater mode
  4. Bring up my other eero mesh network nodes
  5. Everything works.

I suspect if for some reason the HomeBase reconnects to any of my other eero mesh network nodes (any of the non-gateway nodes), then I’ll start running into issues again. Very subtle behavior, because video streaming always works, just notifications, settings updates, and recordings playback don’t work in the ‘bad configuration’ of the eufy HomeBase in WiFi repeater mode. I wish eero had a way to force a device onto a specific node, without it being signal power determined… since I think I may continue running into this problem until eero implement a feature like this.

This recent update is horrible. My homebase always reverts back to Performance mode, yet my cameras inevitably go offline. The process to remove and add them back involved many instances where the sync button would not work. Eventually I got a camera added back and had to leave it alone for a day to successfully mount it. Now 2 days later it is offline again. I’m ready to write this off as a sunk cost and buy another system.