Security Keypad flashes red, after latest update

My Keypad doesn’t connect with the homebase anymore, since the last update on nov. 22.
It flashes red when walking by or when entering a code.


  • tried reconnecting it with the homebase
  • tried adding it as a new keypad, it did connect but then it flashes red again.

Please fix this problem…

If it flashes red while walking past it, the battery is low.
I had the same with my keypad, contacted support and told them about it. Turns out the app is not in sync with the battery stats of the keypad. I got a low battery notification for the keypad about a week or so after it started flashing red.
I did look it up in the manual and it does state that flashing red when walking past it means the battery is low.

My keypads are working fine now after recharging and after the update.
So please recharge the keypad and try again.

1 Like

Hey John0,
Thank you for your respons.

I did actually thought that the battery wasn’t empty, cause the app shows me thats it is full.

I’m charging it now.
Thanks for advise

Will show its full until it dies….

Yeah, found that out the hard way!