SD Card format failed in the 2k Pan and Tilt indoor cam

I recently purchased the Eufy 2K Pan and Tilt indoor cam and am now trying to install an SD Card.
I have two brand new Sandisk Ultra microSDXC UHS-I A1 class 10 cards and and the camera cannot format either of them. It does recognise the cards when I load them and tries to format but each time the format fails. I have completely reinstalled the camera but same result. I have tried the SD cards in my iMac and they load fine and I have reformatted them to ex-FAT and tried again in the Eufy cam. Same result, the card is recognised but the format fails shortly after the format progress bar reaches 99%.
Other than this problem the cam appears to be working fine.
Have raised a query with Eufy but in the meantime would much appreciate any tips/tricks to get it working.

I had the same problem with a Samsung EVO Select 128GB MicroSDXC UHS-I U3 card I bought from a seller on Ebay. I bought the same card direct from Amazon (fulfilled and shipped) and that one worked fine. So, I can only theorize that considering the number of counterfeit name brand memory cards out there, make sure you purchase only ones from reliable sources to make sure you get an authentic one. Other than that I think the max used to be 128Gb but I think a recent software update increased that to 256Gb.

Hello, I’m having the same issue. I bought my sd card from Amazon and no luck. Do you guys think its the camera? I tried the usually, resetting the camera, formatting the card in my pc but no luck.

The SD cards in Eufy devices are formatted ext4 by the device because Eufy uses Linux as an underlying OS. So, formatting in a PC whether as ex-Fat of NFS won’t work. I think some Macs offer ext4 as an option, but don’t have a working Mac at the moment to check.

Anyway, if the card won’t finish the format, suspect the card. Some cards will format fine on a PC or a Mac and fail on Linux. Not sure why, but I’ve seen this before.

I have the best luck with Samsung cards, but there are so many bogus cards these days that its really a crapshoot even from reputable vendors.


Do you know if they actually did increase to 256 gb in an update ? I have a brand new 256 gb card that I would like to use if possible.

The only supported cards are 128 GB according to their specs. I would rather spend a few extra bucks on a “High Endurance” Samsung card at 128 GB than a cheaper 256GB card from someone else. If you buy a good quality card, it will be capable of being written many multiples of cycles and the camera will do this automatically.

I agree , The card I have is a new Samsung “High Endurance” 256 GB . I was hoping I could use it rather than buying the same card in 128 GB simply because I already have this one and have no other use for it right now.

All the Eufy cams I have are running a very old version of linux. NMAP reports (2.6 or 3.1) as an internal OS. Not sure if that is what limits the file size of the card. The file system written to the cards is Ext4 which should allow much larger cards. Maybe its a hardware issue.

If you pull a card and try to read it in a linux PC you can read the logfiles on the card, but all the videos and other data are encrypted.

1 Like

!!! I had the same problem, and it did not work with any type of formatting, but I have solved it. So, you can delete all you want from the app, or you can press the reset button for approximately 10 seconds, and after you hear a double beep, the camera is reset from the origins, and you will have to reconnect with the camera in the app. After you reconnect with the camera, it will give you the option to “format this SD card”, and just press “format”. Everything will be made by itself!!! KEEP the sd card in the camera while you connect with the camera to can have the option of formatting it. Good luck!

Same problem with card refusing to format, but restart didn’t help. Other suggestions welcome.

I have this same issue too. Has anyone manage to resolve?

I saw this thread and noticed that no one has posted any solution. So here we go…

I had the same issue with the Micro SD card that I bought. It’s the 128GB Samsung Evo Plus micro SDXC UHS-1 Class 10 with max speed rating of 130MB/s.

Note that it is important that it is an SDXC UHS-1 type, because SDXC UHS-2 and UHS-3 are not supported. It said on Eufy web site.

The SD card I bought failed to format inside my Eufy 360 pan & tilt indoor camera. Tried a few times and the formatting kept failing.
I then took the card out and format it using my PC using the exFAT format.
After that, I stick the SD card back into my Eufy camera. The Eufy app asked me to format the card again. This time, Eufy was able to format the SD card successfully.

Tested and the card works well recording and playing back the recorded videos.
I hope this helps.


I’m having the same issue.
I bought Samsung EVO SDXC UHS-1 128GB
format it 1st time with Eufy indoor pan and tilt cam with no problem.
but after 1 month it stop recording and the card was full ( I thought it suppose to overwrite )
so I try to format it again since it was full. it will not let me format, keep telling me Format failed and faulty SD card. now I’m wondering if this is SD Card issue or the software issue. I have search everywhere in google but no luck. So I guess my card is useless now. Anyone find the solution? maybe can reformat the card in PC or MAC? Linux? will that work?

fail to firmat sometimes indicting sd card slot has a problem. I have to fix my c24 as the solder hokd down failed. nzmine is manufacturing quality defect.