S380 Homebase just stopped working

I tried to acccess the feed from one of my cameras this morning and the app stated that the Homebase 3 was offline. This happened a few weeks ago and all the circle LED on the front was red. All it took was to simply cycle the power. This time, there was no LED light of any color. I tried cycling the power but still got nothing. No LED light. I checked the power supply with a multimeter and it measured 12.24 VDC, so power is good. I guess that means that it has died. I got it 14 months ago, so it is out of warranty. I don’t suppose anyone has any magic method of reviving a dead Homebase 3, do they?

I would try another power adapter.
I had an issue where my cable TV channel adapter wouldn’t power on, I did the same as you and checked the voltage and it showed good, putting out 9 volts.
Next day a service tech showed up at me home and just swapped out the power adapter and it powered on, go figure.

He told me yeah it could be putting out the proper voltage but, it also needs the proper amps to power on the device.

This could be the issue?

U may try to remove Hard drive first.

I thought that, but I tried it with the power adapter from my working Homebase 2, which is the exact same adapter and it is still dead. I wouldn’t bother with another Homebase 3, but it is required for the eufyCam E330 cameras that I added to my collection. They don’t work with the Homebase 2.

Did that.

Sounds like a board level diagnostic.

Have you tried to contact Eufy. They may replace it with a refurbish unit.

Sadly, they won’t. I traced power to the TVS diode, but no further. @ $0.28/each, I ordered a few and will break out my rework station and see if that is the culprit. If not, I’ll trace again.

Keep us informed.

May be a there was a storm in your area damaged the TVS.

Good luck.