RSTP setup with Asustor surveillance center

Was anyone able to successfully connect the cams through RSTP on the Asustor NAS Surveillance center ?

It seems simple enough on paper, but does not want to work.

Connecting through a browser with RSTP with the generated URL in the app seems to work, but the NAS surveillance center can’t seem to find the camera …

Thanks !

1 Like

I would also be interested in setting this up with Asustor Surveillance center. They say they support 900+ RTSP cameras, but I did not see Eufy in the list with any cameras. They have a number of other vendors. I have the floodlight cam 2 pro. Scan failed and could not see a way to manually add Eufy.

Okay, I was able to go into the Surveillance Center and used the camera settings as opposed to the Quick Start settings. This allowed me to add a camera as user defined and I used the following setttings.
Name: Drive
Brand: User-Defined
Model: RTP over RTSP(TCP)
IP/Host: “local ip address”
Port: 554
RTSP Pathrtsp://admin:Password@ipaddress/live0
RTSP Port: 554
Username: admin
Password: Password

I then did the camera checkmark and it came back green.
Then clicked on Live View and could see the video.
It works as long as I am in the setup guide on the Eufy app.
Status can say disconnected.

Is this the right selection for the Surveillance Center?
Log is showing Camera[ Drive] Detected audio-stream was changed to AAC about every 5-10 seconds.
If I switch from the logs to Live View I then get a Connecting to camera message in red and I do not get a live view until I pull up the Eufy app on the cell phone.

Options for the Model are as follows:
Generic MJPEG
Multiple RTP over RTSP(TCP)
RTP over RTSP (TCP)
RTSP and RTP over HTTP

Trying to verify which settings to use for Model in Manual Config.
Let me know what is recommended.

Thanks.

I tried whole day to get my 2 eufycams to work with my as1102t asustor NAS.

I was able to get one of the cameras to not bring the error “camera not found” with manual mode but still no live feed. And no luck at all trying to set up 2 cameras. I did create a ticket so let’s see if they can help me through that.

But I tried all different settings and multiple times the same settings. Nothing seem to work.

Only time I did not get the error was with rtp over rtsp (tcp) first port on 80 and rtsp port on 554. Rtsp path from eufy and username is my asustor username.

Tho I wonder since my http port is not standard why would it work on 80. Don’t know if the port change is only on out going traffic.

So does anyone have a proper guide for this?

I’ve tried the same setup numerous times as indicated in the April 19, 2022 post. Never seem to be able to get either a live view or a recording. Did find internet reference that said to use port 80 and then rtsp port as 554. The link is: https://www.asustor.com/en/knowledge/detail/?id=&group_id=1403

Also tried all of the options involving rtsp, but the link says to use the RTP over RTSP (TCP) option; none worked.

Perhaps it’s a matter of having the camera operating all the time? I wasn’t able to select the option in the Surveilance Center setup pages to record only motion or alarm or alarm and motion. Also not sure how to set up the record matrix in the edit/record screen.

Is there anyone out there, that has found a solution yet?