No HomeKit live view on Eufy 2K Indoor Cam with error: "No Response. Wait until someone else in this home stops viewing this camera and try again."

I just set up my new 2K Indoor Cam (sole Eufy device on my network) and all went smoothly: updating firmware, HomeKit integration, etc.

But I am totally unable to watch the camera live through the iOS or MacOS Home app, every time getting the superimposed error:

“No Response. Wait until someone else in this home stops viewing this camera and try again.”

I looked online and saw recommendations to reboot devices using HomeKit—which I’ve done. But even with every other device shut down, not one of my devices (iPhone, iPad, Mac) are able to watch the camera live.

I can see it fine through the Eufy Security app, so it’s not like there’s an issue with the camera—and it seems to record fine to HomeKit (and/or the Eufy Security). I thought maybe there was a conflict with Eufy Security recording simultaneously, so I disabled recording in that app, but still no joy.

Anyone have any ideas on this? So appreciate it!



I think it could potentially happen after detecting motion for recording and you tried to view while it is still syncing with home hub. Then it gets stuck in this no response loop. I have had this happen with other brand homekit products too so that makes me think it is a tvOS bug and not eufy. Hard to say though. Could be problems on both ends too.


Same problem here! Nobody else is viewing the camera, but it’s stuck on the “No Response” error message. Sometimes rebooting all associated devices (camera, hub, iPhone) gets it going again, but I’ve had the 2K Indoor Cam for less than 24 hours and this is more often than not my experience while wanting to watch Live. Help!

1 Like

The same just started happening with my indoor and pan 2K cams on HomeKit. Even those not on HomeKit Secure Video.

I’ve had to just wait and then they become available again. All I know, this started happening over the weekend for me. Hopefully firmware updates will fix or from Apple real soon!

1 Like

They pushed me a new firmware to try but I still have the issue. I did notice once I assigned a status IP address for my cameras it was a bit better

1 Like

I still have the same problem with all three of my Indoor Cams. Did anyone find a working solution?
How did you fix the ‘No response’ notification?