No events being saved

Same here in Melbourne Australia. Nothing being saved to look at. I deleted and reinstalled the app and nothing

Hope they can rush through a fix!

1 Like

Same in Melbourne Australia, I think the problem started at 2am this morning, cause my husband got home at that time, received notification but no saved events, hope they will fix it soon….

1 Like

Same thing happen here in NZ.


Same problem in Australia. If you select the month, the calendar has the dot on each day indicating events, but no events show.

I am on Iphone as well. Hmmmm and what is going on?

I’ve discovered this issue seems to be contained to iPhones/Apple devices. My iPhone stopped showing recorded events today, however, I installed the Eufy app on an old Android device and can see past recorded events, including those occurring today 2 April.

It indicates an issue with Apple and the daylight savings change.

Almost 10pm AUS time and still no update on the issue?

Found a solution! Seems to be a time zone issue. I went into time/date on my phone and toggled “set time zone automatically” from on to off (this set mine to London time). Exited out of that menu, and then shut all open apps down. Then went back in and switched it back to “set automatically” (my timezone is NZ) and the events in my app appeared.

1 Like

Indeed changing the phones TZ to London works. So this is a bug and we need to wait for a patch

1 Like

Experiencing the same frustration from three floodlight cameras and a door bell. I receive notifications of events as usual but no stored event clips in the Local Storage.
I will try to reinstall the mobile app and hopefully have some resolution! This problem started on the 2/4/2023.

1 Like

I have the same issue! I have notice one thing that’s different, the option where you choose your storage setting the local storage option has disappeared from the menu there is only one option available and it’s NAS(RTSP) and I have restarted the home base and cameras multiple times but still can’t get the option local storage to come up it’s very frustrating

It still not saved events for Melbourne Australia, but if you change time zone to London, it’s works, what is going on…., can anyone help please

1 Like

I changed the time zone on the iPhone to other country… it’s work, but not work for Melbournr Australia, lol, something wrong….

Ahh yeah as soon as you change time zone back the events go away again. Sorry, didn’t realise this! How strange!!

I had same issues at NZ but all sorted ,turnoff the day and time automatically and reopen the eufy app then turn the automatic back ,it will start save the events:)

To get around this I’ve changed my Timezone from automatic to Port Moresby PNG which is the same time zone as AEST

Will keep this until eufy have a fix.

Hope this helps someone

1 Like

Started working since 12am last night. Didn’t do any changes. Am in NZ.

Did tried update app.
Reformat the memory.
Restart the home base yesterday in 2/Apr.
But nothing helped, so went to sleep.

This morning the “event” back to work and starting to save some movement detected when nothing else has been done. Here in NZ.


Tried the Timezone Port Moresby PNG, and it’s working now for Melbourne Aus, thank you😊

1 Like

Yes, seems to all be back up and running now! Great stuff. Thanks everyone :+1:

1 Like