Naming device too difficult?

I’m trying to install the device for the first time and I’m stuck in naming the device. It always give me a message like “setup fail”.
The names I tried were: doorbell, home, eufycam… nothing works.
Help please.


Sounds like you are duplicating the existing list of names. It probably won’t allow that. Try something totally different like adding the camera type to the name. I have the camera type added to each device and haven’t had any issues. Example… Backyard North 2 Pro

Did you resolve this and how? I’m stuck at this point too, everything I pick results in ‘set failed’ and I have tried different alpha, numeric and alphanumeric combinations. I can’t imagine I’m duplicating anything. If I go back it ends set up but I can’t go forward.

I closed the app because I couldn’t progress past the name. I went back in later and it worked fine but because I was demonstrating how it didn’t work, I picked a ridiculous name… and now I’m stuck with it :joy:

1 Like

You should be able to go into the setup menu for the device and click on the Name field and change it to whatever you want. Make sure to use the Save button at the top when you have it like you want it. I change camera names all the time when I upgrade or trade them around and it works fine.

Not sure what device you are using, but Android needs Storage permissions for the Eufy app to function.

1 Like

I’ve just had same issue.
Clicked the back arrow and found the device named itself.
Click on the setting icon for that device and change the name.