Issue in a accepting family invite on iPhone

I’ve seen other posts about having issues with accepting invite and tried other tips like re-install etc. But still doesn’t work. There is no acceptance button comes up. Can anyone help? Thank you

We are having the same issue. Husband trying to invite me. We already created a new account with a different email address and while I do receive the email notification, when I log in to the app there are no invitations there to be accepted.

Good morning kelly

I have the same issue too. I fix this by email the tech support to do the app account location move on the other account that I want access to camera. On iPhone, it is really hard to identify the location of account location because it does not show in the app.
So, my suggestion is that you email the tech support team at
Title your email as Move location of account in App
type your main eufy account, then
type out all email that you have created eufy account and those are the one you want to get access to your cam
tell them that you want the location of the main account and the sub accounts (the one which you want them to gain access) to matchup . (either US for unites state or EU for europe)
Then include a serial number of one of your camera or product.

Send the tech support these informations. When they finish doing this. All sub accounts can be able to receive invites from the main account.

The error here is because sometime when you create new account the system just randomly choose location for the account without lettling us know .