iOS 15.2, Eufy C22, dual sim, eufy app only working with one sim

I bought a C22 and loved it. Easy to put up, great quality, very happy. Then I decided to check on it whilst on a dog walk and hence forth have spent hours trying to figure out what’s wrong.

I have an iPhone 12 with iOS 15.2 and dual sim in the U.K. (work Vodafone, and personal Voxi). On my home or any other wifi, it works fine. As soon as I’m on cellular the camera won’t connect (live or saved footage) whilst both sims are on. If I switch off a line, the camera works on cellular. Doesn’t matter whether it’s the esim line or the sim line.

If I’m on my home or external wifi and both lines are on, there is no issue and I connect fine.

I have another camera with Yi which doesn’t have any issue. None of my other apps have issue, this is specifically Eufy.

Spoke to Vodafone who recommended a network reset. Strangely this worked for about 20 minutes before it all stopped again.

Apple support are saying it’s an app issue.

I followed some forums telling me to turn off VoLTE but there isn’t an option to do that in my settings on either line. I just see 5G on, 5G auto and 4G in the data & voice settings.

Eufy have clearly not tested their app on an iOS device with dual sim otherwise there wouldn’t be hundreds of reports on the issue. I’m hoping support can help me. In the meantime, has anyone else resolved an issue like this?

I got the same problem. Eufy app doesn’t work on IOS 15.2 with dual sim. This is not a provider issue, the only app that stops working on dual sim is the Eufy app.
Is there a solution other then switching off one sim?

Has been same for months with me as well. iPhone 12 and 13. ESIM EE and Physical Voda, literally the only app with the issue. Asked support, no fault found. Only started at iOS 15 I think. Also can’t remove volte now

Hello,

Same problem here. To get it working, 1 SIM card has to be turned off. Of course not a solution!!!

My configuration:

  • iPhone 12
  • IOS 15.2.1
  • Physical SIM: Vodafone
  • E-SIM: T-Mobile
  • Home Base 2
  • 2K HD video doorbell
  • Cam 2 pro

Hello

I’m in the UK

Im on iPhone 12 Pro max, iOs 15.4 using Eufy latest 4.1.4

I have dual sim
BT for Phone calls (standard SIM)
EE for Data (eSIM)

Using Doorbell (Battery) 2k

Works fine when I switch to BT conventional sim (albeit it always takes ages to connect when someone calls at the door and generally theyhave left by the time I can get a two way link)

If I use the eSIm which is 5G and works flawlessly with EVERY app on my phone for data only, the video feed never works and often I see a header bar “No internet connection”

I have tried to disable VOLTE as some others have suggested but the iPhone 12 doesnt allow Data Options as other models do

I have spoken in depth to EE and Apple who both point the issue with EUFY yet the response I have had from EUFY is as follows

"We have tested the situation where eufy app runs on the Phone with two sims and it works well.

…the root cause may be the sim card or the operation of the dual sims. In your case, it is recommended to disable VoLTE on one SIM and for iPhone 12 and beyond, please help to contact the sim operator to see how to disable VoLTE."

No help whatsoever and negating any responsibility with this clear issue

I wish I knew this before I bought the doorbell as it’s completely useless unless I am in the house on WiFi

Hopefully at some point they may fix this but I’m not holding out much hope!

Possible solution to try! Ok, so I thought no I have a possible workaround for this frustrating issue. I have downloaded Spedify which is a VPN app which allows you to use both WiFi and mobile data simultaneously, I’m not sure why this works, but I think it tricks the app into thinking that it’s using WiFi. I’ve tried running the app even without connecting to a WiFi networks and it finally works! Just to note, this is a work around and Eufy REALLY need to resolve this issue and hope this highlights and proves that their app developers need to sort this out! This issue mainly affect dual SIM devices, so let me know if this has worked for you guys.

Any of you that worked out the problem?
Eufy did try to help me out but the problem remains.

Still only works with one SIM turned off.