HomeKit Not working Remotely

Hi guys, my iOS devices and my Eufy are all on the latest firmware and software versions.

My Eufy 2 Cams and Homebase work flawlessly inside and outside my home wifi. HomeKit works flawlessly on Wifi at home but when i leave the house the remote streaming doesn’t work on HomeKit. All other connected devices work and display status etc, however the EufyCam’s can not stream… is anyone else having this issue? How can i solve it? I have an Apple TV 4K that’s the Hub along with 3x HomePods which are also acting as standby bridges so no issues with remote access for the home.

1 Like

Hi @jonoh,

Thank you for reaching out.

In this case, could you please try the mobile network on your phone and see if it helps?

If the issue still persists, please provide:

  • Your eufy account
  • The serial number on the Homebase

Please send the information to support@eufylife.com. Looking forward to getting you taken care of as soon as possible!

Thanks have emailed support. Hope we can find a solution

I’m having the same issues with my EufyCam E security system. Trying to view remote live streaming or trying to watch recorded video clips is useless away from home. I called Eufy tech support and the guy told me all I could do is to uninstall then reinstall the ap and make sure the Location Permissions is set to “always”. I did that and there was still no change.
Did you ever remedy your situation Jonah?

Hey there … is there any solution to this problem. I am having exactly the same problem here

Did you get it solved.

I am also having the same symptoms as you are reporting here. I believe after the iOS 14 update my cameras stopped working in HomeKit altogether and I had to reset the Eufy Homebase in order to get the Eufy Cam 2 cameras to be available in the Home app again. They now appear and can view the Eufy Cam 2 cameras while at home on my home network they are not accessible from outside my network. I can see the camera stream just fine from the Eufy Security app while outside my network.

I’m not sure if it was the recent HomeBase 2 system update ( that came on 1/11/21 or possibly an update to my Apple TV, but it all seems to be working again. My Apple TV about the same time of the update had a notice in my HomeKit settings that I needed to log into my iCloud account (again?) so I did and noticed a day or so later that I could now access outside of my home network my Eufy Cam 2 cameras via the Home app.

For home kit to work outside your home network you need a ipad or apple tv that is in the house. I dont know but i think it wassent always like this…

7 months and everything has always worked perfectly until a week ago.
Now I’m having the same problem, impossible to connect over 4G/LTE with the Home app.
iPad as a HUB, HomeBase 2 and 2 cams, everything updated and under the same Apple ID.
Under WiFi everything work flawlessly, either Home app or eufy app.
Under 4G/LTE HomeKit is unable to connect to the cameras 9 out of 10 times and when it does only the audio is in streaming, the video is more like screenshots displayed at various delayed time.
If I use the eufy app under 4G/LTE, the connection work perfectly like under WiFi.
I already tried to reset the HomeBase and re pair it with HomeKit, turned off and on the iPad (my HomeKit hub) and I kept it plugged in and with the home app open, but the results are the same, unable to connect over 4G/LTE.
Anybody still have this issue?

The problem is at the mast you connect to and the settings of your provider.
If I use a different provider it works just fine and sometimes it works when I am connecting to different masts.