HomeKit loading issue

Hi Eufy lovers. I absolutely love my 3(for now) eufy cam 2 cameras Which I bought last week and planning to get the doorbell as well when the HomeKit compatibility is sorted. One issue though, it takes ages to load on the HomeKit sometimes. I’m talking about more than 10/15 seconds.
And sometimes it says camera is not responding.
Anybody else experienced this and any tips to sort it out will be appreciated


Thanks for reaching out. If the issue still persists, please send us a screenshot to support@eufylife.com.

Could you please let us know if you are using the wifi network or the mobile data?

Please provide the eufy account and the serial number located on the camera device so we can further assist you.

We apologize for the inconveniences, look forward to hearing back from you and wish you a lovely day.

1 Like

Hi, I installed my 2 Eufycam today and I am having the same issue. But in my case it will always return Camera not Responding after a while. Weirdly enough, I have noticed two things (maybe it is a clue for solving it):

First, I am the only home user with “Stream & View Recordings” enable. The other 3 users are set for “Stream Only” and can load the cameras streams normally.

Second, in the initial screen of the Home app, the snapshot image loads correctly (the image is updated with what is in the camera), but when I tap it to load the stream I get the failure.

But the way, everything works fine in the Eufy app. Besides this issue that I hope gets a fix soon, I am super satisfied with the product.

Add homekit integration in your doorbell like announced for iOS 14 and put me in the preorder list!

Same issues here. I had reported to support the following 2 days ago, yet no response.


I am having an issue with the HomeKit secure video integration.
The moderators at the Eufy Security Community pointed me to this support email.

I am running two Homebase 2, following IDs:
(1) #, system v2.1.0.5h - 4x Eufycam2 connected
(2) #
, system v2.1.0.5h - 1x eufycam2 connected
My Eufy account is under *****@me.com

When I add the Homebase to HomeKit, they work for a little while. But then the cameras cannot be reached anymore - but they still work through the Eufy security app.
A first indication that they stopped working is that the picture on the home app doesn’t update anymore and shows hours as last update of the refreshed picture - I run an iPad at home which shows the home app as main screen 24/7.

I’ve tried deleting the homebares and re-adding to HomeKit multiple times. Both options have been tested, the addition through the Eufy app and as well the option to use the barcode on the home base directly into the Apple home app.

I use two Homebase2, as one does limit me to 4 cameras per your firmware limitations, whereas Apple allows me up to 5 cameras in homekit.

Any recommendations for me?

Actually I figured out what was the issue for me!

I realized something was really awkward when I checked my iPad and the cameras were streaming normally in the Home app. Both are using my AppleID.

After that, I remembered that I use CloudFlare as my VPN/DNS in my iPhone. Turning it off made it work!!

For other people who are having similar issues, I suggest testing with other devices or checking your internet connection (proxy, VPNs, DNS settings). Maybe the solution will be the same as mine.

I still don’t know if the problem is in CloudFlare, Home app or Eufy cameras, but I am fine turning it off when using my home wifi…

I also have a similar issue. Eufy app works fine. HomeKit on iPad usually cannot connect at first. Sometimes turning the iPad Wifi off and on again resolves it, but this is sometimes temporary.
Sometimes it seems to be ok when using Picture in Picture, but not full screen.
As you can gather, it is proving hard to pin down the issue. I’ve not noticed the issue on my iPhone.
iPad OS and iOS are both updated, as are the app and camera firmware.