HomeBase 3 Seagate BarraCuda 5TB Problem

New HomeBase 3 setup fine with cameras just got my Seagate BarraCuda 5TB 2.5 HDD that was recommended for the HB3 in an online article that said it was tested and worked. My HB3 will see the 5TB HDD but only says that it is a 512GB hard drive and formats it as such. I put it in my computer and sure enough the HB3 formatted 11 separate partitions 512GB and some other random and left 500 some odd GB unformatted. Computer see’s that it’s a 5TB hdd and formats it fine in disk manager. drive seems to be working other than HB3 formatting it incorrectly. Called support and was told to replace the drive even though it seems fine other than HB3 not formatting it correctly. Tried a 128GB SSD and a 320GB HDD and they both work fine and formatted fine in the HB3. Why does it not detect that it is a 5TB HDD in HB3?

I’ve read posts about the Seagate 5TB not formatting right away but after a couple tries they seem to get it to work with no mention of it not showing the proper disk size.

I am having the exact same problem.

What was your solution to the problem?

I’ve tried formatting the drive many times but it doesn’t format and gives me an error to try a different drive.