Homebase 2 not connecting anymore

I’m completely lost here and support in the live chat only caused more issues….
Today my homebase lost connection and started showing a red LED. Even though my network is just fine.

I tried several steps to see if I could fix it myself, such as checking the actual network connection and checking the router. All was fine and the device itself was showing in my network.

Contacted live chat support. Got the classic “turning it off and on again”. They also told me to unpair and completely reset it. Now of course nothing is working anymore, not even the alarm itself. And well, I can’t get it set up anymore…. Great support….

Told me to reset my router. This is a business network with hosted services, so I told them the downtime will cost us money. I also told them that in my networking experience. This would not solve it. They insisted and told me I should contact their legal department for my losses… As predicted that didn’t work either, but hey, who am I, only been doing this for 15 years…

Now I’m still stuck with a non working product and useless alarm. Live chat support made it worse and in the end told me to send them a mail for further help. Thought I’d share my frustration and perhaps see if anyone has any tips while I wait for them to get to their mails.

The homebase 2 is stuck at a blue blinking LED. I’m going to leave It powered off for the night in order to get a clean new DHCP lease (I already forced it but we all know that’s not the best way, and perhaps the downtime will reset some stuff in the device itself too).
Any other tips I could try before I throw this out of the window and dump Eufy?

I had a similar experience when I first got my system. Turns out that the homebase was in the process of getting a firmware update and crashed.

After unpairing, power down and back up, and resetting it still wouldn’t work. So I powered it back up, then held Sync button down and pulled the plug. I kept holding the sync button down until the LED went out and then left if for a couple of hours after that to kill any residual charge on the caps. After waiting, I was able to get it connected again and add the devices.

Also, I gave it a reserved address in the router so it wouldn’t get confused. It’s worked fine for about 9 months after that through power dips and an ISP outage.

A note on support. As you have found the hard way, phone and chat are basically worthless. Email gets to the people who can answer your questions, but it takes longer.

Thanks for the reply. So I left it overnight and no dice. Trying several ways of rebooting and resetting the device. Live chat was “sure” that there is no problem with the device but right now it’s stuck flashing red, not even steady. Pretty sure something is seriously wrong with my homebase… I hope their support doesn’t take too long cause the new Ring alarm is out here, might just take the easy way out.

1 Like