Homebase 2 light

I recently noticed the blue light at the front of my Homebase 2 is no longer lit. The Homebase still seems to be functioning properly, however, with no light there is no way for me to tell if the Homebase is online or not by looking at it, I will have to open the app.
I restarted it through the app and also unplugged it for a few seconds but no change. When it’s restarting the red light does come on though.
Has anyone else experienced this? I already contacted Eufy and waiting on thier response.

1 Like

Welcome to the forum @JP118 and thanks for sharing your issue. This is the first time I have heard of it. You did the right thing by contacting eufy support.
Let’s wait for the resolution and please do share it here for the benefit of other members…

1 Like

Is it ever lighting up blue? If everything still works fine, it may be that the blue led is broken.

No it doesn’t light blue at all again. I had the same thought about the LED.

Have you contacted the customer support?

Just an update,
Eufy customer support said they will send me a replacement as soon as they received the old unit and sent me a shipping label. I had an issue with that as my system would be offline during this transition. I expressed this and they are willing to send out the replacement unit first. They said it’s out of stock at the moment though, but as soon as it becomes available they will send it out. I think it being out of stock helped with the decision they took as well :smiley:.
I’ll update again when this happens.

habe exactly the same issue with my homebase2. Everything is working perfect, except the blue light. Has eufy confirmed, that the blue light should be on all the time?

Hi, I knew I couldn’t be the only one, lol. Eufy are willing to change the Homebase because of this issue so that confirms this is not normal operation. At first I thought it may have been a feature in a software update to allow it to be taken off but there wasn’t any. I prefer it on as it’s a way to tell the Homebase is functioning with just a glance.
I advise you contact customer support.

Since Eufy contacted me in November 2020 and indicted they would send me a replacement when they had stock, I had given up hope they would after not hearing from them for months. But they kept thier word and emailed me in early March to say it was dispatced.
I received it and it’s working properly. Apart from the blue light on my original homebase it worked as it should so the only difference is the blue light is on.
Thier customer support was excellent, thier policy was to ship the defective one before a replacement would be sent, but I indicated to them that I would not be comfortable having my home security offline in that period, and they understood and sent the replacement out without me shipping the defective unit. I still have to send it as they indicated failure to do so would void my warranty and with such good service I am not going to risk that so bright and early tomorrow, I’ll be sending it back.
Note Eufy also sent a shipping lable for the return of the old homebase, so they covered all cost.

1 Like

I’m having the same issue. The cameras seem to be working (most of the time). I’ve tried resetting the Homebase. No blue light.

1 Like

Same issue here since a couple of days.
When I do a restart the led turns red.
After a couple of minutes it turns off.
Everything seems to work properly.

Same issue here since a couple of days.

Same issue again, my unit has only been in use 132 days.
Looks like Eufy have a quality control issue.
Next step will be to contact Customer Support.

Update, Eufy are sending a replacement Homebase 2.
Wanted me to return the original first but didn’t argue when I refused.

New Homebase 2 connected and all working ok.
Assuming the postage gets refunded when I send the original back, I’ll be happy.
Can’t fault the Eufy Support team excellent service.

I have the same issue, I cleared the memory as it was full and that was the last I saw of the blue light !

I’ve got the same issue. I have two homebases, the blue light on one is working the other is not. Cameras seem to be operating ok.