Giving device a name, 'set failed'?

Trying to set up the battery Video Doorbell 2K HD, all good until I get to the page that says ‘Give your device a name’ I add a name and after pressing ‘confirm’ it just keeps saying ‘set failed’…even if I try different names.
Any way around this please ?


What names and characters have you tried? There are limitations on what you can use.

Thanks for the reply, nothing complicated, just normal letters and normal words, tried all sorts of things though, same message every time :frowning:

Share one with us. Exactly as typed

1 Like

Same for me…

I tried “test”, “hello”, “doorbell”, “doorbella”…

ridiculous. it takes so long to set up and the final step doesn’t work…

Whats the solution ?

Don’t know of a solution, it’s probably just a glitch. Are you allowed to bypass the naming and complete setup?
I know you can name the device anytime later within the app.

Back out one step in the app. The App will then show the device as added. You can edit from there once the bug is removed from the software.

1 Like