Geofencing Solved

Like many others, I was totally frustrated with the failure of geofencing to work with my Homebase 2 and the outdoor cameras and video doorbell connected to it. I stumbled upon the following solution when setting up geofencing for my Google Nest thermostat. Don’t want to over-universalize my experience, but this is what solved the problem for me in iOS:

Euphy’s support materials state that for geofencing to work you must enable Location Services (Settings —> Privacy —> Location Services) and select Always for the Eufy Security app.

That isn’t enough. I discovered that it was also necessary to—

  • Turn on Background App Refresh (Settings —> General —> Background App Refresh),

  • Select Wi-Fi & Cellular Data from the Background App Refresh options menu, and

  • Toggle Background App Refresh to On for the Eufy Security app.

Now my system toggles between Home and Away automatically every time I leave my house and arrive home, and I am notified accordingly. I have my radius set to Small in the Geofencing settings. Sometimes the system doesn’t switch from Away to Home until I’m in my garage, but it always does switch back.

Now that it works for me, geofencing is a terrific convenience. Hope it will start working for you, too.

4 Likes

I’m glad to hear someone has this working, but perhaps you can report back after a few more days and confirm it’s still working, and how many iOS devices are using the App?*

I checked all three of those settings (in addition to the location services ‘Always’).
They were already set exactly the same as yours however Eufy geofencing still usually works once or twice after re-saving the small radius, but then fails to work again. :confused: All other apps on my phone using Location Services work correctly.

*I wonder if the majority of users having issues are only experiencing it with multiple devices. Maybe I’ll try removing it from the second phone (same settings as above) for a while and see what happens with only one.

EDIT: Nope, no good. Changed so only one device had the app installed and registered. Went for a drive outside the radius for 15mins. The app only switched the modes when I manually opened it both away and at home.

4 Likes

Geofencing is still working fine except for one occasion when the app did not switch until I opened it to check. Then the app switched immediately. This leads me to wonder if the app actually had switched in the background on this one occasion but for some reason didn’t generate the notice that it did.

I have the Eufy app installed on only one device.

Thanks for reporting back. I’ve had this happen too and suspected that… But no, it’s not just the notification delaying:

Mine hadn’t switched back to “Home” so I

  • Walked in front of a camera to check and saw the red light indicating it was recording
  • Waited 2 minutes, opened the app and only then it switched to “Home”

Looked at the ‘Events’ in the App and confirmed the timestamps just to be sure:

  • There was a recording of me walking in front of the camera (“Away” mode)
  • At 2 minutes later there was the notification that it had “Switched to Home mode by Geofencing” corresponding with when I opened the App

If eufy allowed 5 cameras with Homekit Secure Video instead only 4 this wouldn’t be a problem :confused:

Geofencing in the Eufy app has been buggy as hell since day one. I’ve tried ALL of that and more and I’ve still never been able to get it to work correctly on either my iPhone or my wife’s Samsung phone.

Homekit Geofencing works just fine for me but if we are going to be gone for more than a few hours, I still have to manually switch the app to Away for both of us to get notifications.

As far as I’m concerned, Eufy wont ever fix their Geofencing.

1 Like

Exactly what I found. And since HomeKit works perfectly with Location Services I thought I had a workaround:
Configure Geofencing in the eufy Security app, and then setup an iOS “Shortcut” which opens the eufy Security app (and then immediately switches back to the home screen ) when the phone detects I either leave home or return home.

It kind of worked!….Only one problem though is it only works automatically when the phone is unlocked. (If locked it does at least prompt on the Lock Screen that the shortcut needs you to unlock so it can run)

Another simple solution would be eufy allowing their app to interact with Siri but apparently that’s beyond their capabilities too.

1 Like

I can’t get it to reliably work at all.

HB3 with iPhone 11pro and iPhone SE.

All settings for background app refresh, wifi and mobile data, location to always etc as described above were already on. I’ve toggled them on-off-on a few times but no change.

It worked for a couple of days, but then one of the iPhones wouldn’t. I deleted that device, re-added it under same user (owner)…still didn’t work.
Deleted device, created a second account for my wife and added her account as a tenant within the home… then added her device. It worked for 2 days and then stopped working.
Now BOTH phones don’t work. It says “in the zone” when clearly we are not and vice versa.
It’s rubbish !
We manually switch modes now.

So geofencing is still a problem for me. it works fine when I leave my zone and enables the alarm, but doesn’t recognise when I have returned to the zone so doesn’t dis-arm. If I open the app then it does immediately refresh to recognise I am back in the zone.

all settings re location services etc are set correctly. Now today, I have a rec’d message in the app which states:

“Geofencing: Homebases geofecning is unable to work perfectly due to your family or friends phone location service has not been granted location permission. Go to the enabled devices menu to check the details”

Only my phone is connected to the app and only my phone shows under the enabled devices?

Anyone else just rec’d this message?

This trick never worked for me well.
It works when you open app and activate geofencing and then stops working later until you open app again. What’s more frustrating it’s deactivating geofencing itself and then you have to go back and reactivate it again.
I’m really sorry for my purchase because I never know if my cameras are recording when I leave my house or not.
Eufy, you need to fix this damn app, or you’ll lose your customers.

1 Like

I have the same problem also. If you link 2 devices geofencing never works on one and becomes erratic on the other. Thanks to everyone online discussing this problem I learnt to only link one device and it is definitely better. But I do still get alarms go off sometimes when I get home if I haven’t opened the app before entering the property. As mentioned by others due to a lack of confidence in Eufy Geofencing I do check the app often while away to make sure it is armed. Otherwise I like the system but 100% agree the Geofencing needs a software upgrade ASAP or the Eufy brand will be damaged.

Yes have to agree having recently purchased a system, had I known of this issue I may not have brought into this product and will not advise others until fixed.
It would help if the mode options were available to iPhone shortcuts as you could write your on routines.
Or use WIFI as the trigger when home which surely would use less phone battery and do the same job instead of gps location. But schedule integration is a must. Or some other Alexa, Google, iPhone shortcut way to run better mode automation.
It really should be a priority as the cameras are great.

Have to agree, I had been using Nest stuff for years with no major issues, but the cameras are not great. We’ve had horrible times getting the 24/7 recording to work and also the geofencing. Using an SSD drive in our HB3 instead of an SATA fixed the 24/7 recording issues, but the geofencing is almost worthless. When I have seen it work it can drain a phone battery 50% in less than a day.

Glad I still have 2 weeks left in my return window cause I won’t keep this if the geofencing won’t work. It’s 2024 geofencing isn’t exactly rocket science anymore.