Eufycam 2C - both cameras stuck on old firmware

One of my cameras is on 1.6.0 the other on 1.6.1… When I check for firmware it sees a 1.6.5 available but seems to attempt to install it, but doesn’t complete. I tried with the Homebase 2 on both Wifi and Ethernet and it made no difference. I even tried doing a full delete/reset on the cameras. Anyone else have 2C’s that aren’t updating firmware?

I do. Both of mine are on 1.6.1 and I talked to tech support about it and was told I should be on 1.6.2. They said they would send the update out to me but so far they haven’t. So now they are up to1.6.5? I haven’t found away to do a software update thru the app.

Got mine today. They are on 1.6.1 and when I check it says they’re up to date ??

I’ve just checked my cameras which are Eufy Cam 2c’s and they received the 1.6.2 update on the 8th July.

I’ve finally got the EuryCam 2c’s both hooked up to HomeKit :smiley:

I probably misunderstood the options with Eufy app and HomeKit. I assumed you could only use one or the other when I’m fact you can use both. This is great. It means I can use Siri & iOS for some things and use Eufy app when I need 2 way audio etc :).

Just got them
In the house for now so I can test and play with settings.

1 Like

My 2C are on 1.6.1. What’s the latest update? Is 1.6.1 the latest update? Are updates based on where you are globally?

Are your 2C camera batteries draining quickly whilst connected to HomeKit? I had mine connected, was great but had massive battery drain, lost 10% battery in one day! Now all disconnected from HomeKit, battery is great