Eufy wireless 2K doorbell 2-way mute

I also posted on Eufy wireless 2K doorbell 2-way mute - Questions & Answers - Anker Community and was forwarded by @Tank to ask my question here:

I’ve been since last week the proud owner of a Eufy wireless 2K doorbell and I’m impressed by all it’s features.
One thing is bugging me however and that is 2-way talk.
If someone is talking in the microphone I hear this very clear but once I press the little phone button so I can talk myself I’m only hearing the other person very very faintly like there is a heavy dampening mute on the source.
So to have a conversation, I constantly have to press the button if I want to talk so they can hear me, and unpress it if I want to hear them since otherwise it’s barely hearable.
I’m also noticing a button a button silent mode with a speaker icon but pressing logically completely mutes the other person.

I read some topics that this might be due to faulty connected transformers or not enough power to the device but in my case it’s a wireless model without any external power source.

What is wrong or needs to be done differently?

1 Like

@Ice4 @John0 can either of you guys help this fella out please.

1 Like

I tried using the call button and didn’t have that issue. it was like I’m on a speakerphone. @den412
You may want to try the restart option to see if that fixes or contact for more help.
This may be an isolated issue.

Only got the notification for the mention just now…
Did you pump up the volumes for the doorbell and test it again? Tapping the call button once should activate the speaking mode. Mine works fine too