Eufy security iOS app does not work over ATT cellular - iPhone X


When I try to use the app, it does not work over cellular when trying to view the cameras or access them. It only works when I use it over Wi-Fi. I checked to make sure it wasn’t restricted in cellular connection settings either. Anyone have any idea why this issue is happening?


It seems its a common problem since the latest software update. If you get a response from Eufy and you do find a fix let us know

1 Like

@Mat2916 @calvinn92 Unfortunately, this is just another example that showcases Eufy’s troubled updates. They always seem to fix one issue…but create another. :man_facepalming:t2:

1 Like

I’m in the uk and since the last App update having the same issue when using mobile/cellular data

Works fine on Wi fi

My Wife’s app works fine on mobile/cellular and she has the same phone as me just newer! (IPhone XR)

Rang Eufy uk and got the usual fob off that they will need more information to pass to a back end engineer to resolve!

Same here in Australia, what a balls up seems to do it on iPhone 12 and latest update, my old iPhone 6 and ancient iOS system works well


I’ve done the online chat this morning, of little help as they ‘will report it’

I have also emailed screen recording of the app crash happening to eufy support and provided them a link to this forum which contains the same issues reported by multiple people

Wait and see what happens now

Couldn’t agree more. Shows that they don’t really do proper or enough testing before releasing new updates and firmwares.

1 Like

Did all of you guys recently have this issue? The reason why I ask is because I had this issue for several months now actually. Not sure if exactly same issue and it just became more widespread with the more recent updates.

Yes only just happened post last app update

So standard reply received:

“As this is an unusual case, I have to forward your case to our tech team. Rest assured that I will keep you updated once we received the feedback from our specialist within 48 hours.”

Think I’ve had this standard text reply for almost all questions I’ve asked of them!

Absolute sh@!

If only they had a forum that they could look at and see what issues their customers were having :thinking:

1 Like

The reply i got was that they are aware of the issue and hope to have this fixed in the next 24-48 hrs.

On reddit someone mentioned a new update will be available 10 June.

So had another reply requesting me to download the new Beta version that fixes the issue via the ‘TestFlight’ app

Downloaded the new version - eufy security App version 3.0.0 (737) via ‘TestFlight’

It appears to be working on 4g now but just not as well as it did previously on 4g

they recommended uninstalling the old app before running the beta app

How do you download via “TestFlight”?

1 Like

Eufy finally released new update which appears to have fixed the issue. V3.0.1

yes I had to delete old app and re-download from app store. Seems to work ok

I had the same issue and it was very frustrating that you can’t respond to the doorbell when you are out and about, on 4g. I sent an email to eufy who then invited me to test out their beta, I have just downloaded it and tested it out. Worked perfect so far.

Unfortunately their latest app v3.0.1 did not resolve my issue. I can view the cameras in live view when on WiFi but once I am on cellular, the app would not let me view the live view.

I’ve read about this with other devices; I’m guessing this has to do with! some wierd legal issue.

Installing the test app fixed the issue for me. The support however was poor. I even escalated the incident, because the support wanted me to open so many ports on my firewall, that it would become a Swiss cheese :stuck_out_tongue_closed_eyes: This seemed to be related to using dual line on my iPhone. Once I disabled one of the lines this worked as well.