Eufy Family & Guest sharing problem

I comfirm it’s the problem of location EU or US. Eufy customer service is so unhelpful that I have to search for the correction solution.

I have the issue as well, used to be able to share by sending invitation to new account. Now it will not work anymore and only after finding this in the forum confirms that Eufy has an issue with their accounts.

Both my accounts are NL accounts and i am using the same app on the same phone to check.
Wish they would fix it as i am unable to work with this now.


Same issue as the others here.
The invite does not work.
The invitee should not need to add the device. When my wife added the device, i (the admin) lost access to the camera. :frowning:

Needs to be sorted.

Same issue. I just install doorbell today and created admin account with my email address on my iphone and everything works fine.
And I create guest account with my wifes andiod phone and assigned to guest account. gust email can receive the invitaiton email but nothing poped at adriod phone at all.
I am in Australia. Hope Eufy can fix this soon.

I have the same problem eufysecurity …in the other app eufyhome for robovacum was very easy to invite guest… very annoying!!

Hello all, I had the same issue where the account admin kept sending me invites but I would never receive the accept notification. The solution was to use two emails with the same region code on the end. For example .ca and .ca. The admin had a .ca account and was sending to my account. Once I created an email with a .ca account it worked and I was able to get the accept notification.

I think the latest version of the app will let you set a region when you log in the first time. Just make sure that all your invitees and the main account are set up in the same region. Believe that’s been the root of the issue of not receiving the confirmation popup after getting an invitation.

I found an easy workaround. This afternoon I suddenly got problems, the whole app being empty. I started setting up the devices again, but I noticed my partner still had access to the devices. After setting up 2 of my 3 devices I invited her and the invite didn’t get through, while not having this problem before. I also didn’t have access to my prior recordings, while reading devices before made them pop back up. After that I luckily found this topic, noticing I had the same issue.

I had the same issue: me being set to US, her to EU. Then I remembered I also logged in on the website, luckily remembering I logged in on the US website ( I think that triggered an event that my account switched to US. Just on a hunch I thought let’s try logging on an EU-website, this being That fixed my account! I got all my 3 devices back, including all recordings. While at the same time, I lost 2 recordings I had while my account was set to US. It appears that a separate account is generated for US and UK/EU purposes and you can use them next to each other. I guess it all depends on the server that is used.

The solution, long story short:

  • All accounts have to have the same locale
  • Choose the account that is different and log that one in on the website of your choice: for EU locale for US locale

I didn’t even have to log in again on the app, but maybe that’s necessary.

@AnkerSupport -> maybe this helps you fix things?

Dear @eufy_Operation what is the solution here? My spouse still doesn’t get the invite after trying every step mentioned in this thread. It is really frustrating, that there is no faq on the site explaining how this issue can be resolved. Your support is much appreciated.

I already have an account and Eufy Security app installed. I received an invite from a friend who just installed a camera. When I opened the app, I don’t receive the invite notice. I logged out, logged back in…still don’t get the the notice. I uninstalled and re-installled the app…still don’t get the notice.

How do I accept the invite to add friend’s location and camera to the app?

My wife got the invite, but there was no link or app to redirect her. So, we had her download the app, enter her email, and click forgot password. She had tried registering with a new password before the Forgot Password and it said account already exists. Clicking the Forgot Password resolved her login and invite issue. We didn’t have the US or EU issue, both our apps were pointing to the US.