Eufy Doorbell sends signal to mechanical chime for too long

All of a sudden, when I ring the Eufy wireless doorbell with my mechanical chime, it causes it to ding first, then makes the plunger vibrate back and forth for about two seconds (making a loud vibrating sound), then finally doing the song after doing just one short press with the doorbell. How can I tell it to send just one short signal, instead of this long one? It didn’t used to when I first installed it the other day.

Here is a video with audio demonstrating the issue: https://imgur.com/a/db6HG3L 4

I should note that if I select the mechanical chime again in the setup, it works just fine again. I just want to fix this once and for all instead of setting up the chime again every few days indefinitely.

Sounds like there’s a bad connection somewhere on the wiring.

Nope, it’s software. I reset via the “select indoor chime” by simply reconfirming, and it works again. Any other thoughts?

I have the same problem, yet customer service says it is working just fine (2k battery doorbell)

Sounds like the device is confused and is trying to act like a digital chime instead of mechanical. Under Existing doorbell chime there is an option at the bottom of the page to change the type from Mechanical to Digital. I’ll bet if you check it, its set on the wrong one.

It is currently set to mechanical.

Well, I have an interesting solution that may help others in the future. To simulate my fix of “reselecting” the mechanical chime again in the mobile app, I modified the lib from https://github.com/FuzzyMistborn/python-eufy-security and added an extra function that resets the mechanical doorbell setting. The script sits on my server, and runs as a cronjob daily. I think that this should work, and will report again if otherwise. Below lists out what modifications were made to each file in the above-mentioned lib.

params.py:
Added under the class ParamType(Enum):

CMD_BAT_DOORBELL_MECHANICAL_CHIME_SWITCH = 1703

camera.py:
Added the entire new function under class Camera:

async def async_reset_chime(self):
        """Reset doorbell mechanical chime"""
        await self.async_set_params({ParamType.CMD_BAT_DOORBELL_MECHANICAL_CHIME_SWITCH: 1})

New script that calls everything called eufy.py:

import asyncio
from aiohttp import ClientSession
from eufy_security import async_login

username = ""
password = ""

async def main() -> None:
    async with ClientSession() as websession:
        #Create an API client:
        api = await async_login(username, password, websession)

        camera = list(api.cameras.values())[0]
        print("Resetting doorbell chime...")
        camera.async_reset_chime
        #print("Camera parameters: %s", camera.params)

asyncio.get_event_loop().run_until_complete(main())
2 Likes

Thanks for this. The issue I’m having is exactly like @glj123 describes. I really hope someone from Eufy notices this and issues an official fix. I’m going to try @glj123 's python script, but who knows how long that will work.

Want to laugh… @glj123 @RoyalTea I have the exact same issue and spoke to Eufy higher ups and tested the device with a multimeter and in fact it shorts out too long and even if you set it up and it works now… within a day or couple of hours its messed up again. I think when it switches back to AC recharge mode it gets messed up. Either way Eufy is incapable of fixing this. They say it’s not compatible with my mechanical chime and try to avoid fixing it. Think its terrible service really.

BTW the issue is true for everyone I tested who is hard wired. I spent hours helping for this code in python to make it work and even at that I still sometimes get the long chime.

I honestly think Eufy engineers are not competent enough to fix the issue. Their lead engineer doesn’t know what he is doing…