Eufy Doorbell 2k Battery with existing doorbell

I have just bought the 2K battery doorbell and homebase. In the literature it says that it is compatible with existing mechanical chimes. We have an awesome Friedland mechanical chime that i want to be the active chime for the doorbell. Unfortunately I cant find anything that indicates how I can set up my new Eufy to operate that existing Friedland chime.
Any help appreciated

Switch the breaker off and remove the doorbell button from the front of your house. Then connect the doorbell wires to the Eufy.

I think there are videos online. You could use “Rings” install guides.

Thanks Smoothie. I have a mechanical chime. The only instructions I can see suggests bypassing that with a link cable. Are you saying that if I don’t bypass the mechanical chime but leave it in the circuit then it should simply work ok?

Hi @James_and_Lynne_Anth

I have a similar question, did you manage to get this working?

Which chime and transformer do you have? I have the Friedland D753 transformer.


Hi shailesh, have you tried hooking it up to the two doorbell wires you (probably) have at the door already?
If so, that should be sufficient. In the app you can configure whether to use a mechanical or digital chime.

That should work, when you set it up in the app it goes to a bit about the existing chime, whether it’s electronic, mechanical or skip for none.

I set two up on a mechanical chime, once I selected mechanical and once skipped it, both worked, was the first time I’d heard it ring since we moved in.

Thanks @John0 and @Topshelferok

I have not tried it yet. what transformers are you guys using? does it matter? worried it will fly the doorbell if its not correct.

The manual states AC 8-24v (be sure to check it, I’m doing this out of the top of my head).

Noticed in the manual that it works with an 8-24v adaptor, so I wired it up and it is working great, takes power from the wired and can also utilise my existing chime. :slight_smile: thank you all for your help.

1 Like

Thanks @John0. you are correct, and its now working

Glad it’s working and glad to help! :slight_smile: