Eufy 2 Homebase Firmware Failure

Used the ‘Check for HomeBase Firmware > " option in device info and the app pops up a window with “Latest firmware is available:” current firmware is, so I hit the update button. Responds with “All of your devices are being updated, this may take a few minutes”. The app then returns to the devices window and the cameras are showing a blue revolving circle with an up arrow inside, and the message below stating “Updaing HomeBase…” and the HomeBase is showing a status of “HomeBase is updating…”, the status’ stay like this for ages (waited 15mins last time) and when I refresh the app screen by pulling down on the window, no updates have been applied.

I have attempted this firmware update numerous times but the update never applies and the firmware remains on, any ideas on how to successfully update the HomeBase?

Have you tried rebooting the homebase before trying again? Or pulling the power and letting it do a full restart?

1 Like

Thanks RazorBlade, no idea why I didn’t think of that…and yes, that worked !

1 Like

Hey guys!

Glad to know the reset worked!

The good news is we now have the eufy Homebase compatible with the eufycam full range.

If the firmware could not be updated, you can alsoc provide your eufy account and the serial number for the Homebase, so we can upgrade the firmware for you.

Remember your satisfaction is our top priority and we will be sure to resolve the issue for you.