Doorbell 2k No Live Feed or communication via App

New owner just bought a Doorbell 2k.
On first set up it all appeared to work fine then it tried a Firmware update from to
I left it for over an hour but the bar hadn’t moved at all, just sitting at 0%.

When I press the button on the doorbell I get a notification and can see a live feed.

Once the live feed is closed, the app cannot communicate, hence the firmware upgrade won’t work as the app can’t communicate with the doorbell.
I cannot change any settings as all attempts leads to one of two errors

Cannot Connect to Doorbell (-201) or the same message ending in (-3)

Router has been set to 2.4Ghz, phone is connected to 2.4GHz.

Rebooted, reset, removed aand re-added the doorbell and the homehub to no avail.
Live feed does not work via the web portal.
Speed test on 2.4GHz = 85Mbps down and 49Bps up
Switching to Mobile data doesn’t work either.

I have three other cameras all connect and play live feed with no problem.

Just about to stick this useless thing back in the box and return it, the chime is far too loud but I can’t change it.

If your Doorbell 2K has no live feed or communication via the app, try these steps:

  1. Check the Wi-Fi connection and ensure it’s stable.
  2. Restart your doorbell and router.
  3. Verify the app and firmware are up to date.
  4. Ensure the doorbell is within Wi-Fi range.
  5. Reset the doorbell to factory settings if issues persist.


Thanks for the reply.

  1. Confirmed
  2. Done, no change
  3. App up to date, firmware on the doorbell is not but it cannot update without the app connecting to it.
  4. All components are within 2m of the Router
  5. Reset the little hub (with the antenna on) but cannot see a reset pin hole on the doorbell.

I’ve tried just leaving the little hub disconnected and use the homehub2 I use for the other 3 cameras. Same thing happens.

Just seems odd that if I press the dooorbell I get the notification and live feed showing on my phone but any attempt at a live feed using the app or trying to connect and change settings doesn’t work.

Another weird oddity, the Firmware is and a Firmware update fails. After that the app tells me the firmware is up to date at and the newer no longer shows as available…until I reset it back to factory and try again.

I’ve decided to return this piece of junk.
I’m not decided if it is faulty but on the basis I have three other Eufy cameras all working fine, I’m satisfied I know how to connect it.

I’ve spent far too long with this thing.
Resetting, removing and re-adding
Holding the Sync button for 10 seconds then starting over
Disabling my 5Ghz Wifi, disabling my MESH system entirely, rebooting routers, switching phone between Wifi and Mobile Data.

Frustrating that it all works as intended, press the button, chime works on both the bell and the base unit, live feed appears as it should.
Any attempt to change a setting, view live feed or update the firmware fails…every time.
Communication must be established to see the live feed after the button is pressed so why not work when changing a setting??

I was so pleased with the Eufy CCTV cameras I have I almost signed up for cloud storage, so glad I didn’t.

oh no, I’ve literally just posted the EXACT same issue and setup.

I’ve reset it, updated the firmware, powered everything off / on etc but proper live view doesn’t work / still gives 201.

I’ve got exact same issue

can’t update firmware and live feed not playing

can watch recordings

bell rings

going to send back as hours spent and eufy support no email back

did you fix it

Yep last night!

I brought the doorbell indoors so it was vloser to my main router than my homebase and it updated etc and now remote viewing works no problem!

Hope that works for you too

It sounds like you may need to troubleshoot your Doorbell 2k’s connection to the app. Check your Wi-Fi, app settings, and device firmware for any issues. If problems persist, contact technical support for assistance.