Door bell not alerting unless app is in front

I’ve got a few pieces of Eufy sec kit including the doorbell. Initially i thought this was working however noticed more and more callers at the door and I never got a single notification on the phone. On testing it if i have the app open it will go direct to the live view. But if you don’t, phone is locked out as it would be 99.9% of the time you get zip.

This kinda makes the entire doorbell redundant for us. Is there some way to fix this? I mean if its app/android related its not like its an edge case.

I have all the android notifications turn on for the app, and the security profile settings. Like i mentioned it works fine if you have the app open which you similar wont.


1 Like

Just installed my doorbell yesterday and I just resolved exactly the same issue this morning, turns out my phone was killing the background process of the app so the notifications didn’t work until I opened the app.

You’ll just need to exclude the Eufy app from your phones battery saving process and allow it to run in the background :+1:

1 Like

Yeah I tried this but it didn’t work. Battery > Eufy Sec > switch to manual and set everything to leave it running. Still get zero notifications unless the App is actually in front. Would love any ideas. Think we on the right road… I just not sure how to resolve it.

Hmm only other thing I can suggest is checking within the Eufy app settings, on mine there are separate notifications settings for the doorbell and the homebase under notification then notification type.

Might be worth toggling a few and the old phone restart might be worth a try.

Now I look again, I did the background settings via the apps settings not battery. In my phone this way has more options on the next level one of which is allow to run in background might be worth checking that way.

Apps - eufy sec. - Power usage details - app launch. This gives a pop up with 3 options under manage manually that become enabled when you deselect “manage automatically”

Thanks Bruce, That actually takes you to the same page but yes i’ve selected no automatic and enabled auto launch, Secondary launch and Run in background but still wont ring unless the app is actually open on the screen.

Totally feel like that’s the issue though, its suppressing it unless its at the “front”

Really annoying this for me, this was the best feature i was looking forward to when I got all this stuff.

Out of interest what phone are you running it on? Seems to be a whole host of additional feature depending how far from vanilla android your phone is, might well be something specific to your model. With any luck someone on here will have the same :crossed_fingers:

Using the P30 pro. Should be a pretty common phone.

Just reinstalled the app and it appears to be working. Im not going to change any ring tones etc this time. Im just going to leave it as it is and see. At least its working!!

Exactly the same phone as me which makes it even more odd. Glad to hear it’s working for you now though :+1:

Right update on this issue. I’ve tried everything and I cannot get this working consistently.

I exhausted everything with the p30 Pro phone and never got it working right. I got a brand new phone 2 days ago S21 Ultra and again initially when app is install the alerts work fine, When doorbell is pressed I get the alert on the phone and can speak to who ever is at front door.

But exactly as the Pro30 pro if you leave the phone for a good period the alerts stop working! I’ve gone through all the settings on the phone to stop the app being turned off in the background, Eufy security is left completely alone and i’ve disabled ALL power saving function, Still makes no difference.

Now one thing i’ve noticed which initially i thought was just a red herring but Im also seeing it on the new phone and it kinda makes sense that this is the issue. When you have the issue where the alerts don’t show on the phone, if you open the phone and go to the app you get a message at the top on the app saying “Your phone is not connected to the internet” This stays up for a second or so then vanishes. This did the same thing on both phones. So my Theory is that the app is actually loosing internet connectivity when in the background, not that its disable?!

If anyone can help with this it would be appreciated, I can’t believe others don’t have this issue, I’ve tested 3 phones now and they all have the exact same issues. A Sony Xperia, Huawei P30 Pro and a S21 Ultra all running Android. I bet people out there believes this is working but it actually isn’t. Im pretty sure this is also effecting other alerts than the door bell. When you open the phone you seem to get all backdated alerts, “someone spotted in back garden” on your feed but nothing actually pinged the phone at the time.

This app is not working for what ever reason. The fact that this is an Alert model, if your not getting the alerts when they happen then this whole system is pointless.