Cannot Link EufySecurity to Amazon Alexa

Has anyone had trouble linking the EufySecurity Skills to Alexa.

Does anyone have a fix for this?

I’ve tried authorising login on different brownser/devices.

I can’t link mine either ???

Same error here since last night when I wanted to try to relink the skill as my homebase was not working properly with Alexa (unable to arm via routines, was telling me that the system is not responding), went on live chat and they told me everything on their end was working fine and that the problem was on Alexa’s side…

Eufy support told me that Alexa integration is down and it should have been fixed by the end of June.

Still keep getting same message saying can’t link with Alexa

me too, still unable to link i have tried on different browser & also pc still no luck.

Has anyone got a solution to this?

are you able to follow this up since we’re in July now.

1 Like

Having the same problem June has gone, it’s now July!

Can someone look into this ?

Was thinking of getting doorbell but not sure now because of this issue

I was able to enable Eufy security with Echo show the other day pretty quickly.

I’m doing everything it says to do and it just won’t enable in Alexa skills or won’t find device
I’ve just got echo show it’s all up to date and new
I’ve emailed support so hopefully they will have a answer

from my understanding you first need to enable skill for Alexa to identify the device.

But seems like we are all having the issue of linking the skill in the first place.

I have also emailed support hopefully i receive a response soon.

i’ve got the echo show 8 (2nd gen) but having no luck

Same issue, tried on iOS, Android and PC with no success

I managed to link the skill so it seems to be fixed, however I still cannot arm/disarm using a routine, gonna make a separate post.

I was able to link the skill today, haven’t tried anything but to view cameras on Echo and doorbell chime, both seem to be working fine.

I have my system linked but from a couple weeks back motion alerts aren’t detected by the skill any more. I have some light automations on movement detection but no longer works