Can someone help please. I’m not that technically minded

I’ve just installed the 2k battery doorbell and whilst I’m in the house and someone rings the bell, I get to see them on the app, but, when I leave the house and my phone goes to 4g I can’t get any access if someone rings the bell, it just keeps saying it’s trying to find a secure connection. I’ve gone through quite a few things on here and other place to see if there’s something I’m missing, but I just can’t work it out, I’d be really grateful if some help, thank you.
I’m using an iPhone 12 Pro.

When you are at home, assuming you are using the home wifi, have you tried disabling the wifi on the phone so that it uses the mobile network and see if it works then?

Just going through process of elimination to narrow down what your issue could be.

Not sure how much help this will be… but… if I leave my home WiFi (and iPhone vpn on ). And I drive away from my house it will lock up my eufy app. Everything else works … ??? ( didn’t always do this )

So now… before I leave my property… I stop outside of my cams view… turn off my vpn… turn off my WiFi… and reset my phone.

After it reboots I then set all my cameras to away mode and everything works.

There are many many reasons I don’t recommend Eufy to my friends… this is just one reason. Good luck

1 Like

Never thought of that, thank you, I’ll try it !

Thank you… I don’t think I have VPN on my phone, but if I’m reading this right, you’re saying when I go outside, turn my WiFi off of my phone, close my phone down and restart on 4g ? I’ll give it a go, there’s really no point having it if it can’t alert me when I’m away, shame as it seemed like it had so much going for it

Unfortunately this is something new. Every update seems to bring more problems than improvements. And you can’t opt out from their forced updates.

If I could… I would take my cameras as they were out of the box a year ago and never update. Good luck

UPDATE… after holding for 56 minutes i finally got through to someone at support. To be told to delete the app and reinstall it… it worked !!! But took 35 seconds to make the connection, which is apparently my fault even though it was in 4G, so all in all I have a very expensive doorbell that may deter some as you can see it has a camera. !!
Thank you for your help.

1 Like

Excellent! Thanks for replying. Helps people with similar issues.