Camera has been trying to update for >7hrs

The camera has been updating for more than 7 hours and with no end in sight. No update to say what’s going on in terms of how long is left or even if it’s failed altogether and no way to restart/turn off the camera.

Grateful if someone can help

1 Like

Have you tried using the button on the camera to restart it? What have you tried? People say not to disturb an update, but 7 hours is wrong. If it were mine I would be manually restarting it thinking if it’s bricked it was already that way because updates don’t take 7+ hours.

I had the same issue - I first noticed earlier today that the Homebase2 had updated its firmware so I thought I’d check the cameras to see if they’d had updates too.

When using the app: going into settings for each camera and checking for update I see a new option banner that offers either to update to 2.6.2 or to cancel. Naturally I chose to update :slight_smile: and while two of the cameras seemed fine there was just one left appearing to be stuck on updating.

Went on for some time - far longer than I would have expected and as you state it’s impossible to do anything with the camera using the app as you just get an alert stating that the camera is updating.

I tried restarting the Homevase2 through the app and this stopped the updating on the affected camera. When I checked on the other cameras that had seemed fine I see that they too had not updated and are offering the option to do so.

I think I’ll decline for now :slight_smile:

Woke up this morning and what do you know? - they all had updated to 2.6.2 :slight_smile:


I had the same issue cameras were stuck in updating status for hours. My workaround was to connect my homebase to the router via Ethernet. I brung both my cam2s into the house and put on charger. They both updated within 5 mins.