Anyone using Bluestacks and a solo Eufy Camera?

Does anyone have a Eufy solo camera (something like S340) working on a Bluestacks android emulator using a Windows 11 PC?

Since I haven’t been able to get Eufy cloud storage working to view my events I am trying to get it working on Bluestacks. After researching this I found that the newest editions of Eufy software app doesn’t seem to work on Bluestacks, you end up with a white blank page if you install the latest Eufy app on Bluestacks.

Someone pointed to using the Eufy version v4.6.0_1630. I tried that on Bluestacks and it does semi work, no blank page and you see all the menu’s but can not see live views or the events. I am thinking it is because the release date of this v4.6.0_1630 is 3/21/2023 prior to the Eufy S340 camera release. I have tried the next version up from that and other versions as well and all I get is the blank white page if anything is newer than the v4.6.0_1630.

Any suggestions are very welcome. Thanks.

I think someone here does use BlueStacks and has posted some things about it. You may want to search it on here. Maybe they’ll see your post and reply back.
If I recall I think you may need to use an older version of BlueStacks also?

1 Like

A follow up to using an android emulator: I decided to try the MEmu emulator on my Windows 11 PC. I tried various versions of Eufy app on MEmu. I found using the apk version of Eufy V4.7.0_1747 gives me a very fast and very complete Eufy experience that mimics exactly the android phone app of Eufy. I see live views with clear images and see all the events clearly. It works very well.

Eufy app version 4.7.0_1747:

MEmu Emulator:

1 Like

Thanks for posting your findings. I’m sure some folks here will appreciate the work you’ve done… I know it’s time consuming. Trial and error :+1:

1 Like

A follow up on this. I tried using Bluestacks android emulator on more recent versions of Eufy app’s and never got them to work except for the older versions of Eufy. I sent Bluestacks an email to let them know. This is what I got in return:

“We would like to let you know that we tested this app and found that it is currently not working properly on BlueStacks. Our future release may have a fix for this. We request you to check our website ( for all the latest releases, features, and fixes.”

Sounds good that they are at least aware of the issue and most likely will have a fix for it in future releases.

Hi, I tried installing Eufy app version 4.7.0_1747 on Memu emulator but I’m getting white screen after opening app, could you share your Memu System settings that you have perhaps changed?

I haven’t changed any setting for memu, I am using the default settings. I am using memu version: 9.1.3 If you keep getting the blank white screen, work backward with the Eufy versions. Try the next older version till you get it to work. I think I remember reading somewhere that someone was using Eufy version 4.5 where I was able to use 4.7, so you may have to try older versions. I hope that helps.

1 Like