2k video not playing

I have several eufy security products… 2 wired doorbells, 2 1080p floodlights, indoor pan & scan camera. Recently I replaced one of my 1080p floodlights with the new 2k version. The “old” 1080p worked with no problems. The new 2k floodlight is able to view live video no problems, rather quickly when I press play. The 2k camera records video and saves them in the saved video lists as usual. However when I try to view one of the videos the circle keeps going round and round, never starting and eventually it gives up and goes back to a state as if i did not press the play button. You can tell that there is a video being recorded because it takes up space in storage and you can see the video picture in the saved list.

My wifi in the area is excellent and I do video conferencing outside in the area even further that where the light is at.

I tried resetting the device several times and formatting the storage but that doesnt seem to fix it.

Also the sound seems to play but not the video. Since I re-added it it is now saying unable to display live video when replaying clips. I can still see the live video though if I click on the live feed but not on the saved recordings. I’m using the app through a Pixel 4 so my phone is all up to date /rather newish.

As a test i changed to 1080p recording but that doesnt replay either.

Any ideas why I cant play videos but viewing live is no problem?

Does yours work with alexa?

I don’t know/i dont use alexa