2K Indoor Cam Pan & Tilt - Camera is Offline


I bought two of them, and both shows Offline in the main screen, but push messages is comming. If I show push message, shows the short video and I able to watch live feed. When I return to the main screen, or show the setting screen under gear icon shows offline…

I’m trying to use the app in Apple iPhone 12, and the webpage (https://mysecurity.eufylife.com) too.


Exactly the same issue here. It’s driving me mad.

1 Like

Same issue here. Android app works fine. On iPhone ‘offline’ message. New disappointed user here…

1 Like

Same issue here. Using the iPhone app as well.

1 Like

Thanks! Funny, because it is a Homebridge support camera…

Same problem with iPhone11, showin offline. BUT when the notification pop-up, clicl and on the right top edge you can open live stream. It s weird huh?
Please send and upsate to all İOS, iphone X alao same problema

Same here, I tried iPhone 11 and 12, tomorrow I will try an Android device.

I tried the webpage (https://mysecurity.eufylife.com) but it shows offline too.

Same here. iOS 11 pro max

Set up a new pan n tilt today, getting notifications and can play back activity, but no live feed and showing as offline.

Went though set up a few times and on different networks and still the same.

Same in web browser too.

On another note, my existing 2 pan/tilts are going offline and on a lot today too.

Maybe something to do with the breach today and tightening security at their end?

I hope they solve this problem fast.

1 Like

I have the same issue. Just bought the device.

1 Like

It works now!

Mine was also working when i got up this morning.

However, i then moved it back into my office and connected to a different wifi and same problem again.

Offline on the app and no live view, but getting activity playback.

And now appears to be ok!

You have to wait 10-15 minutes, and it goes online!

1 Like

Same here: since yesterday, may 17, two eufy Indoor Cams Pan & Tilt show constantly up as offline (both in the ios app as well as in the web view https://mysecurity.eufylife.com/) – whilst they operate in homekit and even allow access to the live stream via eufy app push notifications.

Deleting and re-adding them does not help. Neither does logging out and back in to the app (or even re-installing it) help.

I have not changed any direct or indirect configuration … tis was caused by eufy.

in my case this does not work

I learned that somehow the settings for my homekit router changed the behaviour and caused the non-usability within the eufy app. even though I havent actively changed them, the device security settings prevented the eufy app from accessing the cams.

I got the same problem, Iphone 7 release 14.4.2.
Offline on the app and no live view, but getting activity playback.

Mine still offline until today, it will only work if unplugged and pluged again but after sometime it’s just back to offline

1 Like